Skip to main content

Quick start

Composable SDK provides typescript entities and helpers for building DeFi apps on top of Mosaic. It's designed to run in any environment that can execute JavaScript

Installation

To install it in your project, simply run yarn add @composable-finance/v1-sdk-typescript (or npm install @composable-finance/v1-sdk-typescript).

Usage

To run code from the SDK in your application, use an import or require statement, depending on which your environment supports.

ES6 (import)#

import { Token } from "@composable-finance/v1-sdk-typescript";

CommonJS (require)#

const composable = require("@composable-finance/v1-sdk-typescript");